Cannot Install concrete-numpy or concrete-ml

when I try “pip install concrete-numpy” I get this error. I have tried other solutions on this community page but nothing fixes this. What should I do?

ERROR: Cannot install concrete-numpy==0.8.0, concrete-numpy==0.9.0 and concrete-numpy==0.9.1 because these package versions have conflicting dependencies.

The conflict is caused by:
concrete-numpy 0.9.1 depends on concrete-compiler<0.24.0 and >=0.23.2
concrete-numpy 0.9.0 depends on concrete-compiler<0.24.0 and >=0.23.1
concrete-numpy 0.8.0 depends on concrete-compiler<0.20.0 and >=0.19.0

Hi @dsmolina,

I think you already installed a different version of concrete-numpy and now you’re trying to update, but version of concrete-numpy is pinned by another dependency.

Could you share the output of pip list to verify if that’s the case?
Thanks.

Hi @umutsahin,

Thanks for your response! No, I have not installed a different version of concere-numpy before, this is a fresh installation. I have attached a screenshot of the result of pip list where concrete-numpy should be (it is not because I have never installed it) and I have version 1.21.6 of numpy if this matters.
image