when I try “pip install concrete-numpy” I get this error. I have tried other solutions on this community page but nothing fixes this. What should I do?
ERROR: Cannot install concrete-numpy==0.8.0, concrete-numpy==0.9.0 and concrete-numpy==0.9.1 because these package versions have conflicting dependencies.
The conflict is caused by:
concrete-numpy 0.9.1 depends on concrete-compiler<0.24.0 and >=0.23.2
concrete-numpy 0.9.0 depends on concrete-compiler<0.24.0 and >=0.23.1
concrete-numpy 0.8.0 depends on concrete-compiler<0.20.0 and >=0.19.0
I think you already installed a different version of concrete-numpy and now you’re trying to update, but version of concrete-numpy is pinned by another dependency.
Could you share the output of
pip list to verify if that’s the case?
Thanks for your response! No, I have not installed a different version of concere-numpy before, this is a fresh installation. I have attached a screenshot of the result of pip list where concrete-numpy should be (it is not because I have never installed it) and I have version 1.21.6 of numpy if this matters.
That could be the issue. NumPy itself is pinned in concrete-numpy to support Python 3.7. Could you create a fully fresh virtual environment with no packages and try installing concrete-numpy?
Also, just to be sure, could you run:
pip install -U pip wheel setuptools
before you run anything else.
Looking forward for your response!
I tried the solution you provided but unfortunately I am still seeing the error.
What’s your hardware @dsmolina?
@umutsahin I am working on Linux CentOS 7.5, 1 CPU core. Is this what you’re asking?
is there anything else I can try?
It seems CentOS 7.5 is using glibc v2.17, but concrete-compiler requires v2.28, at minimum. To solve it, you could upgrade CentOS version, or use Docker inside your current setup.
Hope this helps!