ERROR in installing concrete-ml

Hi guys, I am facing this error when try to install concrete-ml. Please help me with this.

It is noted that I’m using:

  • pip v20.0.2
  • python v3.8.10

Hello, could you try:

pip install -U pip wheel setuptools
pip install concrete-ml


Hi benoit, thanks for your advise.

I already tried that but it seems didn’t work

OK, what’s your OS? and if you’re on Mac, are you Intel or Apple Silicon?

Hum, maybe: could you try pip install concrete-python==2.5, please, ie without the .0 at the end? We have had a problem, and so on pypi, concrete-python is marked at 2.5 (instead of 2.5.0), but what’s strange is that nobody complained about it, yet

I am using Ubuntu 20.04 hosted on an IHPC server. I tried to install concrete-python but it still faces the same error

What’s your libc version? I see in previous issues that it’s related, did you have a look to the previous installation issues, both in Zama Concrete and Zama Concrete ML categories? It may help

My glibc version is 2.31 which is fitted based on documentation, I also saw some previous installation issues but it didn’t work for me

It is noted that I can install concrete successfully with no errors but those errors come when i tried to install concrete-ml

You can install concrete-python (not concrete, which is another thing) successfully but not concrete-ml, you say? it’s very strange, then

Ohh sorry, it was my mistake, I installed only concrete successfully but when install concrete-python, it throws those errors

ok, we have an hint now!

the tech team is back tomorrow, and will help you, I don’t know what to do now, myself. Maybe I would just say: run pip in -v -v -v and give us the copy (not screen copy) such that we can have a look

1 Like

From the output message it seems you have updated /home/dmbui/.local/bin/pip but still use
Could you please try printing both versions with:

pip --version
# and
/home/dmbui/.local/bin/pip --version

Thanks alex, I tried to install by /home/dmbui/.local/bin/pip and it seems worked. Maybe it is related to pip version and management in the OS.

1 Like