Error installing concrete-ml on Ubuntu 20.04

Dear community,

We have been trying to install the concrete-ml library on an Ubuntu 20.04 machine and get an install error, I think related to package dependencies. You can find the trace of running pip install concrete-ml below. We’d appreciate any help.




Could you try running:

pip install --upgrade pip setuptools wheel

This should do the trick.

Let us know if that works.

1 Like


Thanks for your quick reply. I tried that, but unfortunately it still gives the exact same error.


Hello @davidbalbas ,

Which version of python are you running?

EDIT: From the logs it seems that you are running 3.8. We are investigating the issue.


I am running Python 3.8.10. Thanks for looking at this!

Are you in a python virtual environment?

If not, could you try using pip3 rather than pip as follows:

pip3 install concrete-ml


I’ve been having the same issue and followed the solution you gave. It seems that running pip3 instead of pip allows concrete-compiler to install however a new error occurs during the installation of pygraphviz. Below you can find the error message that appears when running pip3 install concrete-ml.

Thanks for the help!

Could you try running apt install graphivz* please?
There are some dependencies to graphviz libraries and not only graphviz.


It worked after running apt install graphviz* and pip3 install concrete-ml again.
Thank you very much!


Great, thanks a lot to the Concrete-ML people for their help and sorry @drob if you had some troubles. We’re going to have some take aways from this issue for our next update to the doc. Cheers